Trailer

GeoffKornfeld
Posts: 16
Joined: Thu Apr 17, 2014 12:09 am

Trailer

Postby GeoffKornfeld » Mon Nov 17, 2014 12:49 am

I am working on an animation that uses a truck almost exactly like this one on your YouTube page: https://www.youtube.com/watch?v=H4ND70nK0A0

I can't seem to make it work, but of course I'm only guessing because there don't seem to be any trailer tutorials available. And the screenshots in the MadCar Help show a very different kind of trailer situation. I assume the problem is that the shapes of the pieces require the helpers to overlap.

Can anyone tell me or show me what I need to do?

Thanks!

GeoffKornfeld
Posts: 16
Joined: Thu Apr 17, 2014 12:09 am

Re: Trailer

Postby GeoffKornfeld » Mon Nov 17, 2014 9:33 pm

Just please tell me why the attached file isn't working, and maybe I can figure out how to make it work on the large truck. In your online help it appears that there is a separate MadCar helper for the trailer, but that doesn't seem to help things either.

Thanks
Attachments
MadCarTrailerTesting_1.zip
(23.34 KiB) Downloaded 10046 times

GeoffKornfeld
Posts: 16
Joined: Thu Apr 17, 2014 12:09 am

Re: Trailer

Postby GeoffKornfeld » Mon Nov 17, 2014 10:00 pm

Okay, I finally figured it out:

Three things are important:
1) While rigging, keep the trailer separate from the car, so that:
2) The MadCar object for the trailer can completely surround the Tongue, and the MadCar object for the car can completely surround the Hitch, without any overlap.
3) The MadCar object for the trailer must use a separate start position from the car that is positioned at the exact distance that it needs to be.

I hope this has been helpful to some of you.

laneforce
Posts: 3
Joined: Sun Oct 04, 2015 7:36 pm

Re: Trailer

Postby laneforce » Sun Oct 04, 2015 7:40 pm

Could someone please post a screenshot of the setup for a trailer? I have not been able to get it to work. I'm confused about what Geoff is referring to as a MadCar object--is that a chassis object? Or a master MadCar helper object?

anvar
Posts: 465
Joined: Sun Jul 11, 2010 12:34 pm

Re: Trailer

Postby anvar » Mon Oct 05, 2015 2:44 pm

laneforce wrote:Could someone please post a screenshot of the setup for a trailer? I have not been able to get it to work. I'm confused about what Geoff is referring to as a MadCar object--is that a chassis object? Or a master MadCar helper object?


here is the demo file with the trailer http://files.rendering.ru/madcar_for_3d ... oScene.zip
and the manual http://docs.rendering.ru/en:madcar#trailers
Attachments
DemoScene_001.png
DemoScene_001.png (164.45 KiB) Viewed 1105293 times

laneforce
Posts: 3
Joined: Sun Oct 04, 2015 7:36 pm

Re: Trailer

Postby laneforce » Wed Oct 14, 2015 5:48 pm

Thank you for the direction, but I have been studying the help file and demo file for quite some time, and its simply not working. My setup is exactly like the demo scene, but the trailer hitch just won't connect. My truck is driving, but the trailer is not following.
A few questions that are not answered in the help file or demo file:
1. How close do the hitch and tongue need to be to each other once locked in order to connect?
2. Are there any issues regarding each of the chassis' positioning with the hitch and tongue that are not mentioned which might cause my setup not to work? Again, I'm doing it just like the demo but it just isn't working. Tried just about everything.
3. What is the best technique for positioning the start objects for truck and trailer so that the hitch and tongue are aligned properly?

Thanks

laneforce
Posts: 3
Joined: Sun Oct 04, 2015 7:36 pm

Re: Trailer

Postby laneforce » Wed Oct 14, 2015 6:13 pm

I figured it out--the 'connect to' button on the hitch is not noted in the manual, and I didn't notice it previously.
Works now.
Thanks


Return to “MadCar”

Who is online

Users browsing this forum: No registered users and 1 guest