Point Cache motion?

m3fs
Posts: 11
Joined: Tue Jan 04, 2011 5:17 pm

Point Cache motion?

Postby m3fs » Thu Apr 28, 2011 12:22 am

Hi, is there a way currently to point cache the vehicle animation? Thanks!

admin
Site Admin
Posts: 448
Joined: Fri Jan 23, 2009 7:44 pm

Re: Point Cache motion?

Postby admin » Mon May 02, 2011 12:13 am

You can use many free scripts if you need to bake MadCar animation.
For example Animation align http://www.jimjagger.com/Pages/Tools/JJ ... te2011.htm

victorwol
Posts: 8
Joined: Fri Feb 03, 2012 7:48 pm

Re: Point Cache motion?

Postby victorwol » Fri Feb 03, 2012 7:58 pm

I don't see how this script can point cache the animation, or keyframe the simulation so it can be exported to another programs, this for what I can see is to align an object to another one...

elpin
Posts: 11
Joined: Thu Sep 29, 2011 1:05 am

Re: Point Cache motion?

Postby elpin » Fri Feb 03, 2012 9:28 pm

Yes victorwol, you take an object (madcar wheel) and translate its motion into another object (real wheel) as keyframes. In other words, keyframe align the real car wheel to madcar wheel.

I also used Bake Transform script for this:
http://www.scriptspot.com/3ds-max/scripts/bake-transform

victorwol
Posts: 8
Joined: Fri Feb 03, 2012 7:48 pm

Re: Point Cache motion?

Postby victorwol » Fri Feb 03, 2012 11:26 pm

Thanks! I'll give it a try... I wish the plugin just have a BAKE function, would be much easier. What I did so far was to export the scene as FBX, that bakes all automatically....

stevesideas
Posts: 35
Joined: Fri Sep 25, 2009 2:30 am
Location: UK
Contact:

Re: Point Cache motion?

Postby stevesideas » Sun Feb 08, 2015 4:54 am

I've tried the JJ animation align script you suggested but this doesn't work at all. I'm using max 2014 with the 2013 version (which should work) but nothing happens.

Secondly, when I try the animation bake script it bakes the animation but I end up with strange rotations that weren't there originally. Not sure if the script is having trouble with gimbal lock or something..it seems to get confused at regular keyframes throughout the animation.

Any other scripts you would recommend or ways of converting the animation to keyframes ?

anvar
Posts: 460
Joined: Sun Jul 11, 2010 12:34 pm

Re: Point Cache motion?

Postby anvar » Tue Feb 10, 2015 2:24 pm

stevesideas wrote:I've tried the JJ animation align script you suggested but this doesn't work at all. I'm using max 2014 with the 2013 version (which should work) but nothing happens.

Secondly, when I try the animation bake script it bakes the animation but I end up with strange rotations that weren't there originally. Not sure if the script is having trouble with gimbal lock or something..it seems to get confused at regular keyframes throughout the animation.

Any other scripts you would recommend or ways of converting the animation to keyframes ?


strange, we still successfully using this particular script in our production

you need to create a copy of the geometry of a car
and make animation with this copy
then transfer the animation to a copy with the animation allign script
but this need to be done for each element

stevesideas
Posts: 35
Joined: Fri Sep 25, 2009 2:30 am
Location: UK
Contact:

Re: Point Cache motion?

Postby stevesideas » Thu Feb 26, 2015 7:50 pm

Hi again. Well, I tried the JJ script and got it working but the result is exactly the same as the bake animation script.

I have attached an image showing the rotation keys in the graph. You can see that the rotations at intervals are offset to the main line. I'm assuming this is where the wheel goes through 369 degrees and has to flip back to 0 degrees (I may be wrong).

When I play the viewport at normal speed these kinks do not show in the animation but if I play at 1/4 speed they are visible. They are also visible at render time.

Additional note. When I play back the madcar version of the animation there is no strange movement visible. It is only when I bake them using either of the scripts.
Attachments
wobble.JPG
wobble.JPG (95.18 KiB) Viewed 44399 times

stevesideas
Posts: 35
Joined: Fri Sep 25, 2009 2:30 am
Location: UK
Contact:

Re: Point Cache motion?

Postby stevesideas » Thu Feb 26, 2015 8:26 pm

Okay. So I think I'm on to something. When you bake an animation the X & Z rotational curves don't have an increasing or decreasing curve over time. They seem to rotate the wheel over a period of time up until 180 degrees and then flip back round to 0 degrees.

For me the Y value values keep moving in one direction. I'll show you what I mean (attached). I have deleted the strange keys for the other 2 values.

Any ideas ? For people to be experiencing these issues with no solution makes me think this plugin needs to be updated to resolve this !
Attachments
keys_.JPG
keys_.JPG (94.51 KiB) Viewed 44398 times

anvar
Posts: 460
Joined: Sun Jul 11, 2010 12:34 pm

Re: Point Cache motion?

Postby anvar » Fri Feb 27, 2015 10:32 pm

we created own script
its in beta
please email us


Return to “MadCar”

Who is online

Users browsing this forum: No registered users and 1 guest