Page 1 of 1

Strange UI behaviour

Posted: Thu Sep 29, 2011 1:38 pm
by elpin
I'm experiencing a strange UI behaviour and I hope you can help me solve the problem.

When I click the Drive button a semi-transparent window pops up which I have to click to activate. Unfortunately it doesn't work. I have to click the Drive button again and then it works. But then it says I have to press Enter to run the simulation, which doesn't work either. When I press it the simulation runs and once I release Enter it stops. I have to hold Enter constantly in order to make the simulation run which breaks all the controls of the car. Is it possible it has something to do with the keyboard driver?

Please download the video below to see what I mean. (3.5MB)

By the way, do you know how come that even though I have suspension Top Stop and Bottom Stops set both to 500mm the wheels are quite close to the chasis in the free fall? I think they should hang down more...

Thanks for help!

Re: Strange UI behaviour

Posted: Fri Sep 30, 2011 1:53 am
by elpin
So it seems like the problem was in the keyboard drivers. I have a wireless dual-receiver keyboard that actually shows up in Device Manager as two devices. So I uninstalled one and now it's fine.

But I'd still like to hear about the thing with wheel Stops.

Now that it's working I have another problem. The whole simulation is in slow motion. Or at least seems to be. It doesn't stutter or anything and I even tried to decrease the samples for the animation but it remains the same. When the car drops at the beginning of the animation it's like on the Moon...

You can see on the video below what I mean:

The video stutters a bit but on a computer the motion is perfectly fluent. Timebase is 30fps.

Re: Strange UI behaviour

Posted: Fri Sep 30, 2011 10:50 am
by admin
Just try to increase "time delay" option.

Re: Strange UI behaviour

Posted: Fri Sep 30, 2011 11:58 am
by elpin
So the problem in the end was a gravity parameter.

We use millimeters in our 3dsmax scenes but MadCar doesn't respect that and sets the gravity like for centimeters - 980,0. I increased the number to 9800,0 and now everything is working as it should!